pyqtdeploy demo build terminates with Project ERROR: Unknown module(s) in QT: x11extras

Damon Lynch damonlynch at gmail.com
Wed Dec 2 15:49:19 GMT 2020


On Wed, Dec 2, 2020 at 9:32 AM Frans F├╝rst <frans.fuerst at protonmail.com>
wrote:

>
> Is there any chance to get a list of those dependencies? Maybe a
> Dockerfile which demonstrates how to build the pyqtdeploy demo (or at least
> PyQt5)?
>
> It looks like Qt5 itself builds perfectly fine and the Qt5 wiki sais all
> it needs is build-essential, libx11-xcb-dev and libglu1-mesa-dev:
> https://wiki.qt.io/Qt5_dependencies
>
> I've definitively installed all of them among many others.
>
> I'll now start debugging pyqtdeploy-sysroot and sip-install in order to
> get an idea what "Unknown module(s) in QT: x11extras" might mean, but maybe
> someone has a list of packages to be installed before running pyqtdeploy on
> a fresh system?
>

Hi Frans,

On Debian like platforms, have you tried libxcb-xinerama0-dev? That could
help.

Best,
Damon
-- 
https://damonlynch.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://www.riverbankcomputing.com/pipermail/pyqt/attachments/20201202/aea4ad3e/attachment.htm>


More information about the PyQt mailing list