[PyQt] No errors reported by deployed application, no functionality either

Kyle Altendorf sda at fstab.net
Sun Feb 7 20:02:59 GMT 2016

On 2016-02-06 19:57, michael h wrote:
>> set 
>> QT_QPA_PLATFORM_PLUGIN_PATH="C:\Qt\Qt5.5.1\5.5\msvc2010\plugins\platforms"
> Qt has some default locations it searches for plugins and platform 
> files. For my apps built with py2exe, i put the needed files in 
> .\platforms (relative to my app's .exe)

Thanks, that did work as an alternative to setting the variable.

> Have you tried something like:
> myapp.exe > out.txt 2>&1
> from cmd?

Very interesting.  That did help it out and the expected messages showed 
up in `out.txt`.  I tried checking all encodings in pyqtdeploy (except 
the Japanese that seemed to not be present in my Python install) but 
that didn't help.  I had previously added cp1252 (IIRC) when that was 
complained about being missing while running from within pyqtdeploy.

So, with this ability to see the messages I was able to get a messy but 
functional .pdy file that creates a `result` directory I can copy to a 
clean virtual machine and run.  Well, I did have to install drivers for 
my CAN adapter, but that's expected.  Thanks so much for the help.  I 
guess I have to continue digging into what is wrong with stdout.  
Perhaps it is a Win10 issue?  At least it is recreatable and without 
pyqtdeploy or PyQt at all, I think.  This exact command prints in Cygwin 
but exits silently and with a 0 exit code (%errorlevel%) in cmd.exe.  
Redirecting does not help in this case though, so maybe not quite the 

"c:/python34/python" -c 'print("blue")'


More information about the PyQt mailing list