[PyQt] PyQt5 error after re-install of Anaconda

Phil Thompson phil at riverbankcomputing.com
Mon May 25 09:17:36 BST 2015

On 25/05/2015 6:30 am, HARRIOTT, John wrote:
> Hi,
> I have been using an Anaconda distro for Python 3.4. on RedHat 6.5
> In order to write Qt5 compatible apps I built the appropriate SIP and
> PyQt5 modules.
> My PyQt5 libs are located in my ~/.local/lib/python3.4/lib/PyQt5 
> folder.
> All was good until Anaconda was re-installed. Now I get the following
> error when I run a python script that requires PyQt5 package:
> "This application failed to start because it could not find or load
> the Qt platform plugin xcb".
> I also notice the same error for other workstations that have Anaconda
> newly installed.
> Any clues as to why this is occurring?
> When I debug my script it succeeds in importing the packages, but dies
> when attempting to create a QApplication object.
> I checked libqxcb has no missing dependents.
> I rebuilt SIP and PyQt5
> Below is a code example:
> import sys
> from PyQt5.QtWidgets import QApplication, QWidget
> if __name__=='__main__':
>                app = QApplication(sys.argv)
>                w = QWidget()
>                w.show()
>                sys.exit(app.exec_())

Something is wrong with your Qt installation.


More information about the PyQt mailing list