[PyQt] (no subject)

steve at bellissimmo.com steve at bellissimmo.com
Tue Apr 29 23:27:03 BST 2014

I'm trying to set up a new dev environment using Windows 7; Eclipse
Kepler; Python 3.3, PyDev and PyQt 5 and I'm having issues getting PyUIC
to generate a python Qt class.  I tried this on Qt4 a week or so ago and
it worked OK but Qt5 is giving me an error message.

I'm using the following setup process (from Google Groups)  mdoified to
match my PyQt5 configuration:

1. Click Run -> External Tools -> External Tools Configurations ...
2. In the resulting dialog, click 'New' icon in the top left
3. Under 'Name' put 'PyUIC'
4. Under 'Location' enter 'C:\Program Files\Python\2.5\Python.exe' or
the path to your Python executable (probably C:\Python25\Python.exe)
5. Under 'Arguments' enter '"C:\Program Files\Python\2.5\Lib\site-
packages\PyQt4\uic\pyuic.py"  "${resource_loc}"' substituting the path
to your PyQt4 installation - be sure also to include the double quotes
6. Change to the 'Common' tab and check 'File' under 'Standard Input/
Output' and enter '${resource_loc}.py'
7. Change to the 'Build' tab and uncheck 'Build before launch'
8. Change to the 'Refresh' tab and check 'Refresh resources upon
9. Click 'Apply' then 'Run'

and I'm getting the following traceback:

Traceback (most recent call last):
  File "D:\Development\Python33\Lib\site-packages\PyQt5\uic\pyuic.py",
line 28, in <module>
    from .driver import Driver
SystemError: Parent module '' not loaded, cannot perform relative import

I'm relatively new to Python so I'd appreciate some help/pointers please

Steve Simmons

More information about the PyQt mailing list