[PyQt] Next Releases of PyQt and SIP

Melton Low softw.devl at gmail.com
Sun Oct 18 18:21:59 BST 2009

On Sun, Oct 18, 2009 at 2:15 AM, Hans-Peter Jansen <hpj at urpla.net> wrote:

> Am Sonntag 18 Oktober 2009 schrieb Melton Low:
> > Executing PyQt4's configure.py on Mac OS X 10.4.11 continues to produce
> > errors.
> > This is on a PPC Mac running OS X 10.4.11:
> > Python 2.6.3
> > Qt 4.5.3 carbon version
> > Sip 4.9.1 snapshots 20091015
> > PyQt4 4.6.1 snapshots 20091014
> >
> > Configuration problem sharted with:
> > Qt 4.5.3 carbon version
> > Sip 4.9.1 snapshots 20091002
> > PyQt4 4.6.1 snapshots 20091002
> >
> > Problem disappeared if I completely removed Qt and reinstalled an earlier
> > version of Qt:
> > Qt 4.5.2 carbon version
> > Sip 4.9.1 snapshots 20091001
> > PyQt4 4.6.1 snapshots 20091001
> >
> > I had posted the problem earlier.  If this is being worked on, please
> > ignore this.  In case the new configure verbose output is useful I am
> > including it as an attachment since it's quite lengthy.
> >
> That line looks suspicious:
> g++ -c -pipe -g -gdwarf-2 -arch
> i386 -Wall -W -DQT_CORE_LIB -DQT_SHARED -I/usr/local/Qt4.5/mkspecs/macx-g++
>  -I. -I/Library/Frameworks/QtCore.framework/Versions/4/Headers
>  -I/usr/include/QtCore -I/usr/include -I. -F/Library/Frameworks -o qtdirs.o
>  qtdirs.cpp
> It looks like it is confused about two Qt installations. Remove one and try
> again.
> Pete
> _______________________________________________
> PyQt mailing list    PyQt at riverbankcomputing.com
> http://www.riverbankcomputing.com/mailman/listinfo/pyqt

Hi Pete,

Thanks for looking into this.

Originally I upgraded Qt 4.5.3 on top of Qt 4.5.2.  That's when the problem
started.  I also tried a clean build by removing Qt 4.5.2 completely
including all the Sip and PyQt4 components inside the Python library
site-packages folder.  Unless I missed a location with bits and pieces of
Qt, there should only be one version of Qt the 4.5.3 version. When the
configure failed, I removed Qt 4.5.3, reinstalled Qt 4.5.2, and reinstalled
Sip then configured and build PyQt4 to completion.

As far as I can tell, on the Mac Qt is installed in several Qt subfolders
under /Developer and in /Library/Frameworks.  It is also in
/usr/local/Qt4.5.  There are also entries in /Library/Receipts which I
believe the installer use to determine whether to do a new install or do an
upgrade.  In the case of a clean build, I manually removed all the Qt
subfolders in /Developer, removed all the folders starting with
Qtxxxxx.frameworks and phonon.framework in /Library/Frameworks, and removed
/usr/local/Qt4.5 as well as the entries in /Library/Receipts.  I also
removed everything starting with sip* and the PyQt4 folder in the Python
framework site-packages folder.

I did find under /Library/Frameworks/QtCore.framework/Versions/ a folder
named "4" as well as two aliases named "4.0" and "Current" pointing to "4".

I did not find a folder named QtCore in /usr/include.  If there is anything
of Qt in /usr/include, I don't know what it is.

I did not find entries for Qt, Sip or PyQt  in the system preferences and in
my user preferences areas.  If there are such entries, they don't have
obvious names.

So I am not sure where you suspect another version may be lurking somewhere.
 Could you point out on the suspicious line where you suspect contains
another version?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20091018/0464b4f9/attachment.html

More information about the PyQt mailing list