[PyQt] Installation problem on OSX

Pim Schellart P.Schellart at student.science.ru.nl
Wed Aug 6 10:28:15 BST 2008

Hello everyone,

I am new to the list so please correct me if I ask my question in the  
wrong way.

Recently I installed the latest version of Qt (4.4.1) and the latest  
version of PqQt4 (4.4.2).
My python installation is from the scisoft package (ESO software  
bundle) version 2.5.1.
Installation of PqQt4 was done using a simple:

sudo python configure.py
(seemed to be necessary because without the sudo it complained about:
IOError: [Errno 13] Permission denied: 'qtdirs.pro')

followed by:
sudo make
sudo make install

This seemed to work.
But if I run the following from within python:

 >>> import sys
 >>> from PyQt4.QtGui import *

I get the following error:

Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
ImportError: dlopen(/scisoft/i386/library/Frameworks/Python.framework/ 
Versions/2.5/lib/python2.5/site-packages/PyQt4/QtGui.so, 2): Library  
not loaded: QtGui.framework/Versions/4/QtGui
   Referenced from: /scisoft/i386/library/Frameworks/Python.framework/ 
   Reason: image not found

At first I thought it might be the `library' with lower case because  
according to find my installation is located at:




So I tried changing `library' to `Library' in pyqtconfig.py and  
Makefile (after configure.py) but this did not solve the problem.

Does anyone have a clue what is going wrong?

Kind regards,

Pim Schellart
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2425 bytes
Desc: not available
Url : http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20080806/dc05deac/smime-0001.bin

More information about the PyQt mailing list