[PyKDE] Compiling eric3 for use with pyqt4 development

Dave Williams happy at opensourcesolutions.co.uk
Wed Feb 22 20:35:40 GMT 2006

On Wed, 22 Feb 2006 20:41:19 +0100
Andreas Pakulat <apaku at gmx.de> wrote:

> BTW: You don't need those 'old' snapshots, PyQt was fixed 1 or 2 days
> after I sent you those files. 
OK but it was good to get something working at least rather than chase more moving targets!

> > a) The need to tweak configure.py to look at QTDIR first because of a shell script of qmake in /usr/bin causing the incorrect path to be deduced.
> How about python configure.py -q <qt directory>? This has always worked
> for me here.
> Tell configure the qtdir with "-q".
Ah OK that works! Mayby I should have spent more time RTFM rather than fixing the symptom!
> > b) The need to explicitly use the -g option because /usr/include/qt3/qconfig.h contains
> Huh??? Probably this is related to the above. Here QTDIR for qt3 is
> /usr/share/qt3, you can find "include", "share", "bin", "lib" and so on
> there. At least here on Debian.

Doesnt appear to be related. My QTDIR points to /usr/lib/qt3 (which is Mandriva decided to put it) and, as you would expect, there are the dir's you mention (alhough not share).
I still get the same problem. Would be interesting to know what your include/qconfig.h has in it. 

> Does Mandriva not deliver QScintilla? You can tell PyQt3's configure.py
> where QScintilla headers and libs are installed, so you don't need to
> install it into /usr/local, /usr or anywhere you might not have
> sufficient rights to write to.

Yes they do albeit they are always some time behind the cutting edge. Ideally I would have done a 100% source code install for all components so I knew where everything came from and could update if/when required.  QT was the exception because it was installed already and was going to break rather too many RPM dependencies to remove it and reinstall from source.  Overwriting an RPM install is asking for trouble.
> > 4b. Build and install PyQt4
> > 	as for pyqt3 but dont need QTDIR set to qt3 any more.
> You need to edit that too? No way, just use -q <qt-dir>. Qt4 doesn't
> need QTDIR at all, all is done via qmake.

Yes Same problem and yes -q fixes it! Mandriva leaves QTDIR defined but I agree you dont need it. 

Sorry if I almost gave you heart failure!!

More information about the PyQt mailing list