[PyKDE] KDE yum repositories not working

Rick Graves gravesricharde at yahoo.com
Tue Nov 30 23:05:10 GMT 2004


I have good news and bad news.

The good news is I figured out a solution to the GPG
key problem -- in yum.conf, for the RedHat KDE
repositories, turn off GPG key checking.

The bad new is this is not working.

I found a list of KDE RedHat repositories here:


I can access some but not all.  For example, on the
first one listed, http://apt.kde-redhat.org/apt, I can
see headers.info on the directory listing, but "access


Anyway, I went down the list, and put all that I could
access into my yum.conf file.  

There are too many unresolved dependencies -- 86 in
all.  I put the screen capture below this message.  

I wondered whether I could install everything up to
eric, and then build eric.  When I got on this list, I
was at the point of upgrading to a more recent version
of sip.  So a while ago I tried just yum upgrade sip. 
No go -- sip requires python 2.3, which is "not

Actually, python 2.3 is installed on this machine, but
not via yum.  I downloaded the rpm's from the python
site, and installed 2.3 separately.  This is OK --


begin quote

Q) Is it safe to install these RPMs on a Red Hat
system? Will they over-write the system python and
cause problems with other Red Hat applications that
expect a different version of Python?

A) The RPMs that start with "python2.3" are built to
not interfere with the system Python. They install as
"/usr/bin/python2.3" and will not conflict with the
system Python unless you are running on a system that
ships the a version of Python which has the same
major/minor number.

To invoke the interpreter with these packages, you
will explicitly have to run "python2.3". Note that all
Python RPMs provided by Python.org and Red Hat provide
a "/usr/bin/python2.3" (or similar, with major/minor
number), even if they also provide "/usr/bin/python".
So, yes, it should be safe. 

end quote

RedHat hard coded python2.2 in some RHEL packages.  I
think they did this so any future python update
incompatibilities would never mess up RedHat's paying
customers.  I am OK with this, considering RedHat's
position in the open source world.

But since I installed python 2.3 outside of yum, yum
does not know about python 2.3.  And the more recent
sip required python 2.3.  So one cannot upgrade sip
via yum.  

Also note on the LONG list of incompatibilities below,
eric needs python 2.3. 

I have come to the conclusion that yum updates are
absolutely impossible on RHEL for any package that
depend on python2.3.

To use eric on RedHat, I think fedora is the only
option at this time.  

Did I miss anything?



long listing below:

[root at Bill root]# yum install eric
Gathering header information file(s) from server(s)
Server: CentOS-3.3 - Addons
Server: CentOS-3.3 - Base
Server: CentOS-3.3 - Extras
Server: RedHat KDE Deutchland
Server: RedHat KDE UK
Server: RedHat KDE USA
Server: Macromedia Flash Player for Red Hat Linux 3
Server: CentOS-3.3 - Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
..............Unable to satisfy dependencies
Package arts-devel needs libstdc++.so.6(GLIBCXX_3.4).
Package libmusicbrainz needs
Package kdevelop needs libc.so.6(GLIBC_2.3.4).
Package kdevelop needs libstdc++.so.6(GLIBCXX_3.4).
Package kdelibs-devel needs
Package arts needs libasound.so.2.
Package arts needs libasound.so.2(ALSA_0.9).
Package arts needs libstdc++.so.6(GLIBCXX_3.4).
Package PyQt needs libstdc++.so.6(GLIBCXX_3.4).
Package PyQt needs python >= 2.3.
Package libtunepimp needs libFLAC.so.4.
Package libtunepimp needs libstdc++.so.6(GLIBCXX_3.4).
Package kdeaddons needs libasound.so.2.
Package kdeaddons needs libdb_cxx-4.2.so.
Package kdeaddons needs libidn.so.11.
Package kdeaddons needs libstdc++.so.6(GLIBCXX_3.4).
Package qscintilla needs libstdc++.so.6(GLIBCXX_3.4).
Package kdesdk needs libdb-4.2.so.
Package kdesdk needs libstdc++.so.6(GLIBCXX_3.4).
Package kdesdk needs valgrind >= 0:2.0.0.
Package gpgme needs gnupg >= 0:1.2.2.
Package gpgme needs libgpg-error.so.0.
Package kdeutils needs libidn.so.11.
Package kdeutils needs libstdc++.so.6(GLIBCXX_3.4).
Package dirmngr needs libgcrypt.so.11.
Package dirmngr needs libgcrypt.so.11(GCRYPT_1.2).
Package dirmngr needs libgpg-error.so.0.
Package dirmngr needs liblber-2.2.so.7.
Package dirmngr needs libldap-2.2.so.7.
Package pinentry-qt needs libstdc++.so.6(GLIBCXX_3.4).
Package gnupg2 needs libc.so.6(GLIBC_2.3.4).
Package gnupg2 needs libgcrypt.so.11.
Package gnupg2 needs libgcrypt.so.11(GCRYPT_1.2).
Package gnupg2 needs libgpg-error.so.0.
Package OpenEXR needs libstdc++.so.6(GLIBCXX_3.4).
Package kdepim needs libXss.so.1.
Package kdepim needs libbluetooth.so.1.
Package kdepim needs libgpg-error.so.0.
Package kdepim needs libidn.so.11.
Package kdepim needs libstdc++.so.6(GLIBCXX_3.4).
Package kdemultimedia needs libFLAC.so.4.
Package kdemultimedia needs libOggFLAC.so.1.
Package kdemultimedia needs libXxf86dga.so.1.
Package kdemultimedia needs libXxf86vm.so.1.
Package kdemultimedia needs libasound.so.2.
Package kdemultimedia needs libasound.so.2(ALSA_0.9).
Package kdemultimedia needs
Package kdemultimedia needs libspeex.so.1.
Package kdemultimedia needs
Package kdemultimedia needs libvorbis >= 1:1.1.0.
Package kdelibs needs hicolor-icon-theme.
Package kdelibs needs libasound.so.2.
Package kdelibs needs libasound.so.2(ALSA_0.9).
Package kdelibs needs libaspell.so.15.
Package kdelibs needs libc.so.6(GLIBC_2.3.4).
Package kdelibs needs libidn.so.11.
Package kdelibs needs libstdc++.so.6(GLIBCXX_3.4).
Package PyQt-qscintilla needs
Package qt-devel needs libXinerama.so.1.
Package qt-devel needs libstdc++.so.6(GLIBCXX_3.4).
Package taglib needs libstdc++.so.6(GLIBCXX_3.4).
Package qt-designer needs libXinerama.so.1.
Package qt-designer needs libstdc++.so.6(GLIBCXX_3.4).
Package gnokii needs libbluetooth.so.1.
Package eric needs python >= 2.3.
Package xine-lib needs libFLAC.so.4.
Package xine-lib needs libXinerama.so.1.
Package xine-lib needs libasound.so.2.
Package xine-lib needs libasound.so.2(ALSA_0.9).
Package xine-lib needs libasound.so.2(ALSA_0.9.0rc4).
Package xine-lib needs libglut.so.3.
Package xine-lib needs libspeex.so.1.
Package xine-lib needs libtheora.so.0.
Package qt needs libXinerama.so.1.
Package qt needs libstdc++.so.6(GLIBCXX_3.4).
Package jasper needs libglut.so.3.
Package kdebase needs libXss.so.1.
Package kdebase needs libXxf86misc.so.1.
Package kdebase needs libasound.so.2.
Package kdebase needs libfontenc.so.1.
Package kdebase needs liblber-2.2.so.7.
Package kdebase needs libldap-2.2.so.7.
Package kdebase needs libsensors.so.3.
Package kdebase needs libstdc++.so.6(GLIBCXX_3.4).
Package kdebase needs libxkbfile.so.1.
Package kdebase needs libxml2 >= 2.5.11.

end of long listing

More information about the PyQt mailing list