[PyKDE] Segmentation faults in pyqt

Diez B. Roggisch deets at web.de
Sat Jun 19 14:44:01 BST 2004


I've been struggling with this for a while now. I've got pyqt in various 
versions running on two machines - as debian testing package, or self-built. 
It works nice and smoothly.

But on the machine I care most about - the one sitting on my desk at home - it 
segfaults - regardless of what I try: latest versions of sip, snapshots and 
debian packages. Also no difference if I use python 2.2 instead of 2.3.

When stracing, the last thing I get from it is this:

lect(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1%\336\0\0\0\0\0\0\0\377\277\326\251\r\10\30\356C\10 "..., 32) = 32
writev(3, [{"1\0\v\0\1\0!\0", 8}, {"-*-*-medium-r-*-*-16-*-ISO8859-1"..., 33}, 
{"\0\0\0", 3}], 3) = 44
read(3, 0xbfffefd0, 32)                 = -1 EAGAIN (Resource temporarily 
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1%\337\0\17\0\0\0\1\0\377\277\326\251\r\10\30\356C\10"..., 32) = 32
readv(3, [{":-ttf-andale mono-medium-r-norma"..., 60}, {"", 0}], 2) = 60
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

These are the various versions of sip/pyqt I tried:

sip-4.0rc3             sip-snapshot-20040329
sip-4.0rc4             sip-snapshot-20040501

PyQt-x11-gpl-3.12               PyQt-x11-gpl-snapshot-20040502

I didn't try every possible cobination - usually one of the sip4 and after 
that a snapshot. When 3.12 was released, I tried that. Building always went 

The only app that doesn't segfault is tut2.py.

Any pointers to how to debug this are appreciated - if neccessary, I'll built 
python, qt and sip/pyqt from scratch as debug versions, but I'd prefer to 
have someone saying that that actually makes debugging possible before I 
undetake that tedious task.

regardless from the trouble at home - where I got the chance to work with 
pyqt, it surely rocks....



More information about the PyQt mailing list