[PyKDE] PyQT Mac OS X (Again)

Phil Thompson phil at river-bank.demon.co.uk
Thu Sep 12 01:57:00 BST 2002

David Bishop wrote:

> Hash: SHA1
> On Wednesday 11 September 2002 05:39 pm, Phil Thompson wrote:
>>David Bishop wrote:
>>>Hash: SHA1
>>>>The status described on the website hasn't changed. The problem is the
>>>>way OS X handles shared libraries and plugins - X11 or native OS X
>>>>support isn't relevant.
>>>Have you tried it on Jaguar?  I have heard that it now ships with dynlib
>>>(or something) to allow more unix-like handling of shared libs*.  I would
>>>be willing to test compile on my iBook, as long as you are willing to
>>>wait :-) (poor little 300Mhz cpu takes a while to do almost anything...)
>>What's Jaguar - apart from a car that I'll buy one day, and a Formula 1
>>team that used to be able to finish races?
> Mac OSX 10.2, released late August.  Notable for updating the underlying bsd 
> layer to the latest FreeBSD 4.x line, shipping with quite a few more open 
> source tools (like python, ruby, and bash), and lots and lots of performance 
> enhancements and bug fixes.
> As you didn't know, I take that to mean you haven't tried it yet, in which 
> case, here I am! :-)  I'm currently in 1/2-time school, more-than-full-time 
> work, with 3 1/2 kids and 3 other OS projects I'm working on (kmamerun, kde 
> studio, and kpilot), so I don't have oodles and oodles of extra time. 
> However, if you give me step-by-step instructions on how to test if pyqt 
> works (is it a compile problem? runtime?), I *will* get it done.

It's a runtime problem - compilation is fine.

I assume then that you are using the X11 version of Qt? In which case 
you can try the 3.4/GPL versions of sip and PyQt now.


More information about the PyQt mailing list