[PyKDE] PyQt/E and gcc 3.2?

Phil Thompson phil at river-bank.demon.co.uk
Tue Sep 3 14:46:00 BST 2002

Michael Lauer wrote:

> Hi,
>>>in my ongoing quest to get PyQt 3.3.2 to compile with Qt/Embedded 2.3.x,
>>>I have made some progress. Patching <tmake>/lib/linux-g++/tmake.conf
>>>eliminates the problem where sip and PyQt detect Qt/Embedded but tmake
>>>still spits out the library and include flags for Qt/X11. Phil, what did
>>>you do to the tmake output in the old autoconf build scheme that it
>>>worked there ?
>>tmake wasn't used in the old scheme.
> Ok, then this is a bug in the new scheme. The tmake output must either
> be parsed to substitute qte for qt and remove all x11 references or sip
> and PyQt must come with an adapted tmake.conf for the embedded build.

Why aren't you using something like <tmake>/lib/qws/linux-ipaq-g++ as 
the value of $TMAKEPATH?

>>>>>>import libsip
>>>Traceback (most recent call last):
>>>  File "<stdin>", line 1, in ?
>>>ImportError: /home/mickey/lib/python2.2/site-packages/libsip.so:
>>>undefined symbol: _ZTI7QObject
>>>Note that I am pretty sure that there are no version conflicts or
>>>side-effects from other builds lying around.
>>>Any insights?
>>No - apart from saying are you really, really sure you don't have a 
>>version lying around compiled with an older gcc?
> Yes I am. Double-checked with a bunch of other systems. So can we call
> this also a bug? It is only occuring on the embedded built (the symbol
> just isn't there in qt-embedded, but it is there in qt-x11).
> May I ask the audience again if you're all using PyQt just on X11 ?
> If not and you don't have these problems, then please speak up and tell
> me where the fault could be.

Note that I'm still on gcc 2, not tried gcc 3 yet.


More information about the PyQt mailing list