pyqtdeploy demo build terminates with Project ERROR: Unknown module(s) in QT: x11extras

Phil Thompson phil at riverbankcomputing.com
Wed Dec 2 11:11:33 GMT 2020


On 02/12/2020 10:43, Frans F├╝rst wrote:
> Sorry for the messy first post - I thought I could use monospace 
> fonts..
> 
> Here it is again in a readable format:
> 
> I'm experiencing the same issue as stated here:
> https://www.riverbankcomputing.com/pipermail/pyqt/2020-September/043203.html
> but unfortunately Chris gave up and switched to iOS..
> I've also asked a question on Stackoverflow:
> https://stackoverflow.com/questions/65059086/project-error-unknown-modules-in-qt-x11extras
> 
> Are there any updates?
> 
> I've tried to build the demo on Ubuntu 18.04, Debian 10, Fedora 31,
> Fedora 33 with all development related packages installed I can
> imagine, but I'm facing the same error again and again.
> 
> In native and dockered systems I've installed the following packages:
> python python3 python3-pip build-essential libssl-dev zlib1g-dev
> pyqt5-dev libqt5x11extras5-dev libgles2-mesa-dev
> With pip Ive installed pyqtdeploy, sip, and PyQt-builder
> 
> I also experimentally (desperately) installed all Qt5 or X11 related
> dev packages (i.e. *qt5*-dev, *x11*-dev)
> 
> Then I tried to build the demo:
> 
> tar xf pyqtdeploy-3.1.0.tar.gz
> cd pyqtdeploy-3.1.0/demo
> python3 build-demo.py --verbose
> 
> Building Qt5 seemed to work fine but when it comes to PyQt5 I alway get
> 
> ... 2h of compilation ...
> Running 'sip-install --qmake
> /home/me/pyqt5/demo/sysroot-linux-64/Qt/bin/qmake --no-distinfo
> --concatenate 2 --no-docstrings --verbose'.
> Querying qmake about your Qt installation...
> /home/me/pyqt5/demo/sysroot-linux-64/Qt/bin/qmake -query
> This is the GPL version of PyQt 5.15.0 (licensed under the GNU General
> Public License) for Python 3.7.7 on linux.
> Found the license file 'pyqt-gpl.sip'.
> These bindings will be built: QtCore, QtNetwork, QtGui, QtWidgets, 
> QtX11Extras.
> Generating the QtCore bindings...
> Generating the QtNetwork bindings...
> Generating the QtGui bindings...
> Generating the QtWidgets bindings...
> Generating the QtX11Extras bindings...
> Generating the .pro file for the QtCore module...
> Generating the .pro file for the QtNetwork module...
> Generating the .pro file for the QtGui module...
> Generating the .pro file for the QtWidgets module...
> Generating the .pro file for the QtX11Extras module...
> Generating the top-level .pro file...
> Generating the Makefiles...
> /home/me/pyqt5/demo/sysroot-linux-64/Qt/bin/qmake -recursive PyQt5.pro
> sip-install: '/home/me/pyqt5/demo/sysroot-linux-64/Qt/bin/qmake
> -recursive PyQt5.pro' failed returning 3
> Info: creating stash file /tmp/tmp1_ng3eyh/.qmake.stash
> Reading /tmp/tmp1_ng3eyh/QtCore/QtCore.pro
> Reading /tmp/tmp1_ng3eyh/QtNetwork/QtNetwork.pro
> Reading /tmp/tmp1_ng3eyh/QtGui/QtGui.pro
> Reading /tmp/tmp1_ng3eyh/QtWidgets/QtWidgets.pro
> Reading /tmp/tmp1_ng3eyh/QtX11Extras/QtX11Extras.pro
> Project ERROR: Unknown module(s) in QT: x11extras
> pyqtdeploy-sysroot: execution of 'sip-install' failed: returned exit 
> code 1
> 
> I'm running out of ideas.. Can someone provide me with a hint how to
> locate the problem? What does "Unknown module(s) in QT" mean?
> 
> Is there a distinct list of dependencies needed for PyQt5 on Linux and
> for Linux? I've read
> https://www.riverbankcomputing.com/static/Docs/pyqtdeploy/demo.html#building-the-demo
> as recommended by Phil but I think I've installed all dependencies one
> can think of..

...but clearly not all that are required. The requirements will be 
distro-specific, distro version-specific and Qt version-specific.

Phil


More information about the PyQt mailing list