[PyQt] sip version error from PyPI.
phil at riverbankcomputing.com
Tue Apr 9 19:48:05 BST 2019
On 09/04/2019 22:27, Vincent Vande Vyvre wrote:
> Trying to install PyQt5 from PyPI in a 3.7.2 venv, I've this error:
> (py372_venv) vincent at djoliba:~/CPython/py372_venv/demosaicing$ pip
> install pyqt5
> DeprecationWarning: Using or importing the ABCs from 'collections'
> instead of from 'collections.abc' is deprecated, and in 3.8 it will
> stop working
> from collections import Mapping
> Collecting pyqt5
> PendingDeprecationWarning: encoding is deprecated, Use raw=False
> 100% |████████████████████████████████| 61.2MB 196kB/s
> Collecting PyQt5_sip<4.20,>=4.19.14 (from pyqt5)
> Could not find a version that satisfies the requirement
> PyQt5_sip<4.20,>=4.19.14 (from pyqt5) (from versions: )
> No matching distribution found for PyQt5_sip<4.20,>=4.19.14 (from
> Must I've to install sip separately ?
No, but you might want to upgrade pip.
More information about the PyQt