[PyQt] pydeployqt: No 'ntpath' module

Phil Thompson phil at riverbankcomputing.com
Tue May 29 14:27:34 BST 2018

On 29 May 2018, at 12:31 pm, anton.kustov <anton.kustov at banuba.com> wrote:
> pyqtdeploy UI configurator application doesn't have "ntpath" package in list
> on on "Standard Library" tab. As result I can't launch my compiled
> application. I've got an error: 
>  File ":/pathlib.py", line 4, in <module>
>  File "bootstrap.py", line 971, in _find_and_load
>  File "bootstrap.py", line 953, in _find_and_load_unlocked
>  ModuleNotFoundError: No module named 'ntpath'
> I tried to manually add "<StdlibModule name="ntpath"/>" element inside
> "Project" element in my "my_application.pdy", but the result didn't change.
> There is still no "ntpath" package in "pyqtdeploy-build" output while
> Freezing.
> "pyqtdeploy-build" version is 2.1.
> host and target: macos-64
> PyQt5_gpl-5.10.1.tar.gz
> Qt5 installed version is 5.10.1
> Python-3.6.4.tar.xz
> sip-4.19.8.tar.gz
> How can I solve the issue?

The attached patch should fix it.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: ntpath.patch
Type: application/octet-stream
Size: 507 bytes
Desc: not available
URL: <https://www.riverbankcomputing.com/pipermail/pyqt/attachments/20180529/f1aea977/attachment.obj>

More information about the PyQt mailing list