[PyQt] PyQt5 segmentation fault on raspbian pi3

Ronald Burke rsb at empesh.com
Tue Oct 10 00:49:07 BST 2017

I'm uncertain whether this is an appropriate message for this list. If 
not, say so and please accept my apologies.

I am testing a pyQt5 gui on a raspberry pi3. I get identical results 
with both raspbian jessie and stretch.

I first got the error libEGL warning: DRI2: failed to authenticate. I 
seem to have solved that by establishing symlinks to all libEGL and 
libGLESv2 following this model
sudo ln -fs /opt/vc/lib/libEGL.so /usr/lib/arm-linux-gnueabihf/libEGL.so.

The next error was ** (python3:1422): WARNING **: Error retrieving 
accessibility bus address: org.$.
This seems to be "solved" by export NO_AT_BRIDGE="1".

Now I am getting an intermittent Segmentation Fault. The script usually 
seems to fail when the python routine implementing the .ui form is first 
loaded. Occasionally, however, it works perfectly. The script always 
works on my desktop LinuxMint18.

I am using QtCreator 5.7 on my desktop to create the .ui file. I 
transfer it to the pi where I run pyuic5 (installed with 5.7) with 
python 3.5.2.

Any ideas what would cause the seg fault?

More information about the PyQt mailing list