[PyQt] pyqtdeploy and libintl on Ubuntu.

John Hackett john.hackett at icon-is.co.uk
Fri Oct 30 18:37:47 GMT 2015

thanks again. That worked - running "make" outside of the `pyqtdeploy" GUI and after making this change allowed the build to complete. Now I have another issue but I think it's to do with an external module needing to be put in place correctly. I'll look at that later. 

Again, thanks Phil. 


John Hackett 
Icon Information Systems 
74 Gibsons Hill, Norbury, London, SW16 3JS 
t: 020 8764 2663 
f: 020 8711 3370 
m: 07801-231118 
e: john.hackett at icon-is.co.uk 
w: www.icon-is.co.uk 
skype: john_hackett 
twitter: @iconinfosys 

----- Original Message -----

> From: "Phil Thompson" <phil at riverbankcomputing.com>
> To: "John Hackett" <john.hackett at icon-is.co.uk>
> Cc: pyqt at riverbankcomputing.com
> Sent: Friday, 30 October, 2015 3:39:49 PM
> Subject: Re: [PyQt] pyqtdeploy and libintl on Ubuntu.

> On 30 Oct 2015, at 12:05 p.m., John M. Hackett <john.hackett at icon-is.co.uk>
> wrote:
> >
> > On running pyqtdeploy qmake succeeds but make fails with "/usr/bin/ld
> > cannot find -lintl" error.
> >
> > I am running on a newly installed ubuntu 14.04 container (openvz). Googling
> > for this error has not generated much useful information - I have gettext
> > and libc6-dev installed. "ldconfig -p | grep intl" does not give any
> > results so the library has not been installed with either of them.
> >
> > There are some references to similar issue on MacOS but not much relating
> > to Ubuntu and I can't find where I get get the library itself to install
> > it.
> >
> > I also installed both "libintl-perl" and "libintl-xs-perl" just in case but
> > still get the same problem.
> >
> > There was a comment here - http://ubuntuforums.org/showthread.php?t=1505519
> > "Sorry, Ubuntu does not support libintl." Is that true? If so how can I
> > use pyqtdeploy on Unbuntu? Or do I have to go through the setup process
> > again with another distro (Centos? Fedora?). I really hope not as its
> > taken about a week to get to this stage!
> >
> > Is there somewhere I can get the source code so I can statically compile it
> > and add it to the SYSROOT directory?

> First of all try removing the -lintl from the Makefile generated by qmake to
> see if it actually needed.

> Phil
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://www.riverbankcomputing.com/pipermail/pyqt/attachments/20151030/aec3f17f/attachment.html>

More information about the PyQt mailing list