[PyQt] sipEnumType_alloc: Assertion for PyQt5 but not PyQt4

Dmitry Shachnev mitya57 at ubuntu.com
Thu May 28 14:03:31 BST 2015


On Thu, 28 May 2015 13:54:43 +0200, Guðjón Guðjónsson wrote:
> PyQt5 5.3.2
> Sip     4.16.7
> the versions in Debian unstable.

I just tried to import PyQt5.QtWidgets in a clean sid chroot, and that
worked fine.

Does it happen for you every time you try to import PyQt5? If not, can
you please attach a minimal file you can reproduce the problem with?

Or does it only crash when you import your Qwt library?

> #4  0x00007fffee1f4f3b in sipEnumType_alloc (self=<optimized out>,
> nitems=<optimized out>) at siplib.c:11997
> #5  0x00000000004bdd07 in ?? ()
> #6  0x0000000000000001 in ?? ()

#5 is the most interesting part, actually :)

Dmitry Shachnev
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20150528/935d8459/attachment.sig>

More information about the PyQt mailing list