[PyQt] pyqtdeployed app doesn't find time, datetime

Andrea Peter pedrudehuere at hotmail.com
Mon Jul 28 14:02:55 BST 2014

so here I am with my pyqtdeployed application (thanks Phil for the 
response of 2014/07/13), I run qmake and make successfully,
but when I launch the generated executable it says:

ImportError: No module named time

I boiled it down to a tiny python script which I then pyqtdeploy'd, 
qmake'd and make'd:

import time
print("it is %s" % time.time())

Same result, I did that with /datetime/ too, same result.

I built python with /time/ (and others like /datetime/, etc.) as static 
modules (via the Modules/Setup file),
if I open the used interpreter and do:

import time

it says:


instead of indicating the .so file as it does normally. I think that 
indicates they are static, right?
also, in the standard library in lib-dynload /time.so, datetime.so/ are 
not present, another hint that they are built statically, right?

Any ideas?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20140728/e58c3d2a/attachment.html>

More information about the PyQt mailing list