[PyQt] pyqtdeployed app crashes on launch

Dave Gradwell davegradwell at yahoo.co.uk
Tue Jul 8 15:56:10 BST 2014

Ah, you are right, it looks like _fix_up_module was perhaps added in Python 3.4.1.

I tried checking everything in pyqtdeploy -> standard library tab -> importlib section ... but I got the same error.

I think I will try Python 3.4.0, or perhaps the latest 3.3.

Thanks for the message though - it pointed me in the right direction.

Best, Dave.

On Tue, 8/7/14, bootch at nc.rr.com <bootch at nc.rr.com> wrote:

 Subject: Re: [PyQt] pyqtdeployed app crashes on launch
 To: pyqt at riverbankcomputing.com
 Date: Tuesday, 8 July, 2014, 15:03
 Your latest error doesn't seem to be
 a failure to import, rather something else (that I don't
 recall seeing.)
 Just guessing that bootstrap_....  is part of
 pyqtdeploy, you could read the code, which is open source.
 Or if it is part of Python, you could also read that code.
 Or wait for someone else to respond.
 Remember that when you execute your app, it is totally
 divorced from the installed Python.
 Any errors are coming from the Python interpreter and
 modules that pyqtdeploy compiled into your app bundle.
 You might try rebuilding from scratch.  Although a lot
 of time passes, you can read a book.

More information about the PyQt mailing list