[PyQt] Packaging Error in python-qt [Linux-RPM]
hpj at urpla.net
Fri Jun 29 21:49:04 BST 2012
On Thursday 28 June 2012, 11:05:51 Phil Thompson wrote:
> On Thu, 28 Jun 2012 10:48:21 +0200, Sascha Manns
> <Sascha.Manns at open-slx.de>
> > Hello Phil,
> > Am Donnerstag, 28. Juni 2012, 09:27:03 schrieb Phil Thompson:
> >> On Wed, 27 Jun 2012 21:48:10 +0200, Sascha Manns
> >> <Sascha.Manns at open-slx.de>
> >> wrote:
> >> > Hello mates,
> >> >
> >> > i'm trying to package the python-qt and sip components for our
> >> > Plasma Active
> >> > Stack.
> >> > I'm using PyQt-x11-gpl-4.9.3.tar.bz2 and sip-4.13.3+hg20120627.
> >> > The sip component is packaged as "sip" and sip is added as
> >> > and
> >> > Require in the python-qt4 spec.
> >> > But python-qt4 makes trouble. I'm getting:
> >> >
> >> > + python configure.py --confirm-license --qsci-api -u
> >> > Error: This version of PyQt requires SIP v4.13.3 or later
> >> >
> >> > How the configure.py script detects the right version?
> >> By importing the sipconfig module.
> > Do you have any ideas how i can check, why the sipconfig modules
> > gives
> > false version?
> > Do i need any other Build Depencies than your SIP Package?
> I don't know - you are not using packages I provide. I don't provide
> .bz2 files and I don't know what sip-4.12.3+hg20120627 is.
just check my packages on OBS:
While they are bit rotten¹ for a while now, the basic specs are sound -
all new builds are triggered from scripts, which are running for more
than nine month without any human intervention - therefor the outcome
is still pretty high ;-)
¹) Beg my pardon, but I'm continuesly overloaded ATM - I will look for
these things as soon as possible (which doesn't mean anything)...
More information about the PyQt