[PyQt] pyrcc4 changed?

David Beck dbeck at ualberta.ca
Tue Jul 10 00:17:20 BST 2012

Okay, after rebooting the computer, the following worked

pyrcc4 -py3 rsrc/images.qrc -o images.py

I have no idea why rebooting my computer had anything to do with it. Before reboot, this syntax gave me an error message.

Note that this is not consistent with what the man page for pyrcc4 -h says, which puts the options before the input file. 


On 2012-07-09, at 3:07 PM, Phil Thompson wrote:

> On Mon, 9 Jul 2012 14:22:50 -0600, David Beck <dbeck at ualberta.ca> wrote:
>> Has something changed with pyrcc4 in PyQt 4.9.2?
> No.
>> I have a .qrc file (built
>> in QtCreator 2.5.0) that converted into a .py file fine with PyQt 4.8.x
> but
>> which now fails to convert properly (none of the button icons or
>> backgrounds it contains show up in the application when I run it).
>> I'm using the terminal command 
>> pyrcc4 -o -py3 rsrc/images.qrc > images.py
>> Is that wrong?
> Yes.
>> (As I said, it worked before … ).
> Not when run like that.
> Try pyrcc4 -h
> Phil

More information about the PyQt mailing list