[PyQt] Problem with pyrcc / compression

Giuseppe Corbelli giuseppe.corbelli at copanitalia.com
Tue Mar 15 13:35:00 GMT 2011

Hi all
weird situation happening with PyQt 4.8.3/Qt 4.7.1/Python 2.6.6 on Linux.

I create a .qrc like the one attached. Then I "compile" it using

cowo at cowo:~/tmp/x$ pyrcc4 -verbose -compress 9 -o r_application_rc.py
PyQt4 resource compiler
Processing 1 files
Interpreting r_application.qrc
Outputting code

The file within is also attached. It's a simple INI file renamed to .py
because I need the text within to be translated. It's UTF8 encoded but I don't
think it should make any difference.

The r_application_rc.py is built and some data is put in. However, when I run
the (also attached) test.py, nothing is returned. The resource is opened but
appears to be empty.

If I run pyrcc4 without compression everything works fine.

            Giuseppe Corbelli
WASP Software Engineer, Copan Italia S.p.A
Phone: +390303666104  Fax: +390302659932
E-mail: giuseppe.corbelli at copanitalia.com
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: r_application.qrc
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20110315/28139303/attachment.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: manual_controls.ini.py
Type: text/x-python
Size: 3290 bytes
Desc: not available
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20110315/28139303/attachment.py>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.py
Type: text/x-python
Size: 156 bytes
Desc: not available
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20110315/28139303/attachment-0001.py>

More information about the PyQt mailing list