[PyQt] Comppiling QScintilla with python 3.2

Algis Kabaila akabaila at pcug.org.au
Wed Jun 15 02:04:32 BST 2011

After  long trepidation, I started moving my python scripts from python 2.x to 
python 3.2.

Pleasant surprise - sip-4.12.3 and PyQt-x11-gpl-4.8.4 compiled without 

Python 3.2 IDLE does not work well with this version of PyQt. Anyway, eric 5.x 
would be better, so it is necessary to install python 3 version of QScintilla.  
Downloaded QScintilla-gpl-2.5.1.tar.gz, expanded the tar ball and attempted to 

Changed the current dir to QScintilla-gpl-2.5.1/Python/ and tried the first 

$ python3.2 configure.py

It immediately responded with the message:

"Qsci/qsciglobal.h could not be found in /usr/include/qt4.  If QScintilla is 
installed then use the -n argument to explicitly specify the correct 

I am using a freshly installed kubuntu 11.04 "natty" OS and had a python 2.x 
version of QScintilla installed from ubuntu binaries.  I thought that the 
message may simply be because of the installed binaries, so "completely 
removed" the installed QScintilla with the aid of "synaptic" program and tried 
to repeat the first step of compilation.  It  failed again with an identical 
message.  I suspect I am doing  someting wrong, but what?

So where do I go from here?

Your help will be greatly appreciated.


More information about the PyQt mailing list