[PyQt] memory leak on a Mac

Danny Shevitz shevitz at lanl.gov
Thu Jan 27 16:51:32 GMT 2011


I have an app that works just fine on the one click windows distro. 

I just tried to run the same app on a Mac for the first time. I am nobody's
Mac expert, but I did manage to get the latest PyQt4, Sip, QScintilla working.

When I run my app on the Mac, I get the following:

macshev:elm3 shev$ python elm3.py
2011-01-27 09:02:06.705 Python[16663:613] *** _NSAutoreleaseNoPool(): Object
0xae0e30 of class NSCFNumber autoreleased with no pool in place - just leaking
Stack: (0x97805f4f 0x97712432 0x97714c3a 0x22c36b7 0x232ecca 0x232f126 0x1e60363
0x1e65287 0x1023d6 0x4f49a6 0x497caa 0x53a916 0x53da4b 0x53eb8b 0x53ed42
0x562c4b 0x563a53 0x574248)

The app still runs, but evidently I am leaking memory. My app is pure PyQt, no
C is involved. I can't even begin to guess how to diagnose this problem.
Does anyone have any ideas? 

MacOs 10.5.8
Python 2.6.2
sip 4.12.1
PyQt 4.8.3
QScintilla 2.4.6


More information about the PyQt mailing list