[PyQt] SIP install - 'Permission denied' error on Mac 10.4

Eric Coetzee ericcoetzee at gmail.com
Sat Oct 10 19:04:15 BST 2009

I am a PyQT newb trying to install on OS X.

 From the docs, it seems I must first install SIP using the following  
1. python configure.py
2. make
3. make install

But is get "permission denied" during the make install.

The documentation says "Depending on your system you may require root  
or administrator privileges", so i tried
  sudo -u admin make install

which does not seem to accept the password. (admin is an account with  
admin privileges)
I have tried to repair permissions and I've also tried installing SIP  
while logged in as admin - same result.

Can anyone help?

output of step 1
This is SIP 4.9 for Python 2.5.1 on darwin.
The SIP code generator will be installed in
The SIP module will be installed in /Library/Python/2.5/site-packages.
The SIP header file will be installed in
The default directory to install .sip files in is
The platform/compiler configuration is macx-g++.
Creating sipconfig.py...
Creating top level Makefile...
Creating sip code generator Makefile...
Creating sip module Makefile...

output of step 2
cc -c -pipe -Os -w -DNDEBUG -I. -o main.o main.c
cc -c -pipe -Os -w -DNDEBUG -I. -o transform.o transform.c
cc -c -pipe -Os -w -DNDEBUG -I. -o gencode.o gencode.c
cc -c -pipe -Os -w -DNDEBUG -I. -o export.o export.c
cc -c -pipe -Os -w -DNDEBUG -I. -o heap.o heap.c
cc -c -pipe -Os -w -DNDEBUG -I. -o parser.o parser.c
cc -c -pipe -Os -w -DNDEBUG -I. -o lexer.o lexer.c
c++ -headerpad_max_install_names -o sip main.o transform.o gencode.o  
export.o heap.o parser.o lexer.o
cc -c -pipe -fPIC -Os -w -DNDEBUG -I. -I/System/Library/Frameworks/ 
Python.framework/Versions/2.5/include/python2.5 -o siplib.o siplib.c
cc -c -pipe -fPIC -Os -w -DNDEBUG -I. -I/System/Library/Frameworks/ 
Python.framework/Versions/2.5/include/python2.5 -o apiversions.o  
cc -c -pipe -fPIC -Os -w -DNDEBUG -I. -I/System/Library/Frameworks/ 
Python.framework/Versions/2.5/include/python2.5 -o descriptors.o  
cc -c -pipe -fPIC -Os -w -DNDEBUG -I. -I/System/Library/Frameworks/ 
Python.framework/Versions/2.5/include/python2.5 -o qtlib.o qtlib.c
cc -c -pipe -fPIC -Os -w -DNDEBUG -I. -I/System/Library/Frameworks/ 
Python.framework/Versions/2.5/include/python2.5 -o threads.o threads.c
cc -c -pipe -fPIC -Os -w -DNDEBUG -I. -I/System/Library/Frameworks/ 
Python.framework/Versions/2.5/include/python2.5 -o objmap.o objmap.c
c++ -c -pipe -fPIC -Os -w -DNDEBUG -I. -I/System/Library/Frameworks/ 
Python.framework/Versions/2.5/include/python2.5 -o bool.o bool.cpp
c++ -headerpad_max_install_names -bundle -undefined dynamic_lookup -o  
sip.so siplib.o apiversions.o descriptors.o qtlib.o threads.o objmap.o  

output of step 3
cp -f sip /System/Library/Frameworks/Python.framework/Versions/2.5/bin/ 
cp: /System/Library/Frameworks/Python.framework/Versions/2.5/bin/sip:  
Permission denied
make[1]: *** [install] Error 1
make: *** [install] Error 2

output of step 3 with sudo
Sorry, try again.

More information about the PyQt mailing list