[PyQt] problem in making pyqt up and running...

Baz Walter bazwal at ftml.net
Sat Nov 21 18:08:35 GMT 2009

python.noob wrote:
> Hi friends,
>              I've recently changed to ubuntu 9.04.. I've not had any problem
> with the installation of pyqt as it is available from the ubuntu
> repositories with umpteen number of packages.. Anyhow i've to download
> tarball file for python 3.1 and installed it.. I found that PyQt4 supports
> python 3.1(Am i right?)..
> I wanted to check the pyqt installation with a sample program..
> import sys
> from PyQt4 import QtGui
> app=QtGui.QApplication(sys.argv)
> widget=QtGui.QWidget()
> widget.resize(250,150)
> widget.setWindowTitle('Simple')
> widget.show()
> sys.exit(app.exec_())
> when i issued the command
> $python simple.py
> it worked perfectly since it's executed with 2.6 installation..
> But when i tried to execute it with
> $python3 simple.py
> it showed the error like
> ImportError: No module named PyQt4
> So i searched the sys.path for 2.6 and included
> /usr/lib/python2.6/dist-packages
> in python3 sys.path...
> Now when i tried to run this with python3 :working: the error is like..
> ImportError: /usr/lib/python2.6/dist-packages/PyQt4/QtGui.so: undefined
> symbol: PyString_FromString :confused:
> I got the same error when i tried to execute another program... So can u
> please tell me how to solve this problem?? Am i heading in the right
> direction???... %-|%-|

each python installation needs a pyqt4 which has been compiled for it.

please see the installation instructions here:



More information about the PyQt mailing list