[PyQt] api problem with sip 4.7.9, PyQt 4.4.4 and Python 2.5.2 on Mac OS X 10.5.6

Phil Thompson phil at riverbankcomputing.com
Mon Feb 16 13:14:36 GMT 2009

On Mon, 16 Feb 2009 13:53:48 +0100, Romuald Riem <rriem at free.fr> wrote:
> Hello,
> I've just installed the last stable version of sip (4.7.9) and PyQt  
> (4.4.4) on Mac OS 10.5.6. with the default options.
> When I try to run a program I've this error:
> Traceback (most recent call last):
>    File "debitSE-test.py", line 8, in <module>
>      from PyQt4 import QtCore, QtGui
> RuntimeError: the sip module supports API v3.0 to v3.7 but the  
> PyQt4.QtCore module requires API v3.8

Looks like you have an older SIP module installed which is getting


More information about the PyQt mailing list