[PyQt] Problem buildling PyQt 4.3.x

Charles Chen charles.chen at temboo.com
Wed Jun 11 09:41:51 BST 2008

I'm trying to build the commercial version of PyQt 4.3.x.  I get the 
following error:

mingw32-make[1]: Entering directory 
I_LIB -DQT_CORE_LIB -I. -IC:\Python25\include 
-IC:\Qt\4.3.3\mkspecs\default -
/Qt/4.3.3/include\ActiveQt -IC:/Qt/4.3.3/include\QtGui 
ore -IC:/Qt/4.3.3/include -o sipQAxContainerQAxWidget.o 
  `QMetaObject QAxWidget::staticMetaObject' is private
sipQAxContainerQAxWidget.cpp:3428: error: within this context
mingw32-make[1]: *** [sipQAxContainerQAxWidget.o] Error 1
mingw32-make[1]: Leaving directory 
mingw32-make: *** [all] Error 2

I'm using:
Python 2.5.2
Qt 4.3.3
Sip 4.7.6
PyQt PyQt-win-commercial-4.3.3

    I've tried compiling against Qt 4.3.5, but I received the same 
error.  I also tried using PyQt-win-commercial-4.4.2, but it requires Qt 
4.4.x (ie. it fails because QGraphicsWidget is missing).

    I actually don't need QAxContainer, so I considered building the gpl 
version of 4.3.3 (this is for internal development, not for a commerical 
release.)  Unfortunately old versions of PyQt don't seem to be archived 
at Riverbank Computing's website.

    Given that Trolltech is continuing to support the 4.3.x line (ie. 
they release Qt 4.3.5 after Qt 4.4), will PyQt do the same?

    Our project can't go to 4.4 yet, for other reasons.


More information about the PyQt mailing list