[PyQt] Regression in sip 4.7.4 "sip: QPixmap has not been defined"

Adam C Powell IV hazelsct at debian.org
Sun Apr 13 13:55:08 BST 2008

On Sun, 2008-04-06 at 20:14 -0400, Adam C Powell IV wrote:
> On Mon, 2008-04-07 at 00:49 +0100, Phil Thompson wrote:
> > I said before you should reproduce the problem with the standard source 
> > packages, not your distro's packages. "-t Qt_3_3_8b" does not come from the 
> > standard source packages.
> > 
> > Phil
> As we say in New York, "Akhaa!"  Thanks, that was exactly the clue I
> needed.
> This wasn't the fault of the distro, but the software package.  Salomé
> comes in a package with its own SIP, Ot, omniORB, NetGen, etc., and its
> own set of default but non-standard build options.
> Removing the -t option you identified overcame the problem, now it works
> with sip 4.7.4 in Debian, which should be faithful to the original.

The whole thing builds now with -t Qt_3_3_6.

And I identified the source of the Qt version in the sip command: Salomé
gets it from QT_VERSION_STR in qglobal.h .  Debian's Qt has 3.3.8b.

So naturally, I tried -t Qt_3_3_8 but that failed in the same way as

This begs the question: given that Qt 3.3.8 was released on February 14,
2007, and SIP 4.7.4 was released on February 12, 2008, why does SIP not
support a Qt version released nearly a year earlier?

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Engineering consulting with open source tools

More information about the PyQt mailing list