[PyQt] compiling sip on vista

Tom Brown brown at esteem.com
Thu Jul 26 19:56:03 BST 2007

On Thursday 26 July 2007 11:52, Tom Brown wrote:
> On Thursday 26 July 2007 11:41, b b wrote:
> > yes, same error
> >
> > C:\sip-4.6>mingw32-make
> > mingw32-make[1]: Entering directory `C:/sip-4.6/sipgen'
> > makefile:29: warning: overriding commands for target `.c.o'
> > makefile:26: warning: ignoring old commands for target `.c.o'
> > gcc -c -O2 -w -DUNICODE -DQT_LARGEFILE_SUPPORT -I. -o main.o main.c
> > gcc: installation problem, cannot exec `cc1': No such file or directory
> > mingw32-make[1]: *** [main.o] Error 1
> > mingw32-make[1]: Leaving directory `C:/sip-4.6/sipgen'
> > mingw32-make: *** [all] Error 2
> Do you have MSYS installed? I ran into problems compiling when I had the
> MSYS bin path in my system path. I don't remember what kind of errors I
> got, but this seems familiar.

Oh wait, now I remember. I had to add C:\MinGW\libexec\gcc\mingw32\3.4.5 to 
the system path to get things to compile. I think that is what Arve told you 
in an earlier post. If that didn't fix the problem, I'm not sure what else 
you could try. Sorry.


More information about the PyQt mailing list