[PyKDE] Auto-connecting Slots

Gerard Vermeulen gerard.vermeulen at grenoble.cnrs.fr
Sat Jan 28 19:18:25 GMT 2006

On Sat, 28 Jan 2006 17:59:56 +0100
Andreas Pakulat <apaku at gmx.de> wrote:

[ .. ]

> > I mostly dislike the packing scheme of PyQt4, but I see where it's coming
> > from, and as long as I'm allowed to use the "from QtCore import *" without
> > polluting the global namespace, it's still good. Adding "signature" would be
> > a serious problem.
> Again, I do see your point (now) and I do agree, that PyQt4 should not
> "forbid" the from QtCore import * by using such a general name for a
> function.

Huh, I see:

from PyQt4.QtCore import *
from PyQt4.QtCore import signature as pyqtSignature
import signature from signature

as a minor inconvenience instead of a serious problem.

When I did a dir(PyQt4.QtCore), I also grepped my python library for signature
and I found only one function called signature in a package (scipy) which behaves
like a good citizen.

I do not think I will be taken seriously if I ask to rename XX.name to XX.XXname
because it collides with YY.name when I do:
from XX import *
from YY import *

signature is just easier on my mind (and fingers) than pyqtSignature (admittedly
a minor inconvenience, but the Python package system is there to resolve name

I understand that you like to take an unrecommended shortcut and pollute the global
namespace (Q-, q-prefix or not), but it is no reason to make life harder for people
who don't.

The only reason to rename signature is to prevent future name classes with Qt itself
(highly unlikely IMO).


More information about the PyQt mailing list