[PyKDE] debian's python-kde3 horribly broken

Sebastian Kügler sebas at kde.nl
Thu Mar 31 00:40:07 BST 2005


I am working on a couple of KDE applications with PyKDE and noticed that 
python-kde3 broke with the latest upgrade (for both ports, i386 and pure64). 
I cannot import most of the pykde modules anymore, getting the following 

miro.sebas(~): python
Python 2.3.5 (#2, Mar 27 2005, 09:43:31)
[GCC 3.3.5 (Debian 1:3.3.5-12)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import kdecore
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
RuntimeError: the sip module supports API v1.0 to v1.0 but the kdecore module 
requires API v0.2
>>> import kdecore

As you can see, if I import kdecore a second time after it failed, it works, 
so I suspect some missing import somewhere, but wasn't able to track it down 
to a specific module. I tried rebuilding the package python-kde3 from the 
latest snapshot from http://www.riverbankcomputing.co.uk/pykde/download.php , 
sadly to no avail. Here's an strace of the above action (importing kdecore 2 


Building of the snapshot went fine on pure64, although it didn't fix the 
problem, but on i386 (with alioth's 3.4 packages), I get the following 
compile error:

make[1]: Entering directory `/usr/src/pykde/python-kde3-3.11.3'
make[2]: Entering directory `/usr/src/pykde/python-kde3-3.11.3/dcop'
g++ -c -Wno-deprecated-declarations -pipe -fPIC -g -Wall -W -D_REENTRANT 
-DQT_THREAD_SUPPORT -I. -I../extra/kde340 -I/usr/include/kde 
-I/usr/include/python2.3 -I/usr/share/qt3/include -I/usr/X11R6/include -o 
sipdcoppart0.o sipdcoppart0.cpp
sipdcoppart0.cpp:2924: error: syntax error before `[' token
sipdcoppart0.cpp:2935: error: syntax error before `[' token

(full log available at: 

Earlier (last week's) versions of the packages for both archs worked fine. 

versions now installed:

ii  python-sip4-dev          4.1.1-1 
ii  python-sip4-qt3          4.1.1-1 
ii  python2.3-sip4-dev       4.1.1-1 
ii  python2.3-sip4-qt3       4.2.1-1 
ii  sip4                     4.2.1-1 
ii  python-kde3              3.11.3-3 
ii  python-qt-dev            3.14.1-1 
ii  python-qt3               3.13-4   
ii  python-qt3-doc           3.13-4   
ii  python-qtext             3.13-4   

ii  python-sip4-dev          4.2.1-1 
ii  python2.3-sip4-dev       4.2.1-1 
ii  python2.3-sip4-qt3       4.2.1-1 
ii  sip4                     4.2.1-1 
ii  python-kde3-doc          3.11.3-3 
ii  python-qt-dev            3.14.1-1 
ii  python-qt3               3.14.1-1 
ii  python-qtext             3.14.1-1 

Can someone help?

Thanks in advance,

  http://vizZzion.org   |   GPG Key ID: 9119 0EF9 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Great people talk about ideas. Average people talk about things. Small people 
talk about people. (Dave Marinaccio)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 481 bytes
Desc: not available
Url : http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20050331/36f1895e/attachment.bin

More information about the PyQt mailing list