[PyKDE] make error

tim timgunning at dsl.pipex.com
Mon Mar 15 00:26:01 GMT 2004

tim wrote:

> hi all
> been trying to get this up and running all afternoon and have worked 
> my way through all the probs up till now, but am now a little stumped.
> Im running (sid) and downloaded the source (PyQt-x11-gpl-3.11) for the 
> sip files, built using the "deb-src 
> http://people.debian.org/~rcardenes sid main" from a
> tia


well I chmod'd and chown'd everything and it went a little better but we 
stalled at the following.

make[1]: Entering directory 
g++ -c -pipe -w -O2 -D_REENTRANT -fPIC  -DSIP_MAKE_MODULE_DLL 
-I/usr/share/qt3/mkspecs/default -I. -I../extra/kde313 -I. 
-I/usr/include/python2.3 -I/usr/include/qt3 -I/usr/include/kde 
-I/usr/include/qt3 -o kdecorehuge0.o kdecorehuge0.cpp
/usr/include/kde/kprocctrl.h: In constructor `
/usr/include/kde/kprocctrl.h:139: error: `
   KProcessController::KProcessController()' is private
sipkdecoreKProcess.cpp:2088: error: within this context
/usr/include/kde/kprocctrl.h:140: error: `
   KProcessController::~KProcessController()' is private
sipkdecoreKProcess.cpp:2088: error: within this context
/usr/include/kde/kprocctrl.h: In destructor `virtual
/usr/include/kde/kprocctrl.h:140: error: `
   KProcessController::~KProcessController()' is private
sipkdecoreKProcess.cpp:2093: error: within this context
/usr/include/kde/kprocctrl.h: In function `PyObject*
   sipDo_KProcessController_setupHandlers(PyObject*, PyObject*)':
/usr/include/kde/kprocctrl.h:131: error: `static void
   KProcessController::setupHandlers()' is private
sipkdecoreKProcessController.cpp:339: error: within this context
/usr/include/kde/kprocctrl.h: In function `PyObject*
   sipDo_KProcessController_resetHandlers(PyObject*, PyObject*)':
/usr/include/kde/kprocctrl.h:132: error: `static void
   KProcessController::resetHandlers()' is private
sipkdecoreKProcessController.cpp:362: error: within this context
sipkdecoreKProcessController.cpp: In function `PyObject*
   sipDo_KProcessController_slotDoHousekeeping(PyObject*, PyObject*)':
sipkdecoreKProcessController.cpp:467: error: no matching function for 
call to `
/usr/include/kde/kprocctrl.h:120: error: candidates are: void
/usr/include/kde/kprocctrl.h: In function `void
/usr/include/kde/kprocctrl.h:140: error: `virtual
   KProcessController::~KProcessController()' is private
sipkdecoreKProcessController.cpp:511: error: within this context
/usr/include/kde/kprocctrl.h: In function `PyObject*
   sipNew_KProcessController(PyObject*, PyObject*)':
/usr/include/kde/kprocctrl.h:140: error: `virtual
   KProcessController::~KProcessController()' is private
sipkdecoreKProcessController.cpp:564: error: within this context
sipkdecoreKApplication.cpp: In function `PyObject*
   sipDo_KApplication_xioErrhandler(PyObject*, PyObject*)':
sipkdecoreKApplication.cpp:2645: error: no matching function for call to `
/usr/include/kde/kapplication.h:1140: error: candidates are: int
make[1]: *** [kdecorehuge0.o] Error 1
make[1]: Leaving directory 
make: *** [sub-kdecore] Error 2


(this was after amending as per Fred's post 

ive now removed everything and reinstalled from the deb (apt-get 
build-dep python-kde3), run python build.py which has completed without 
error, run make and its just produced the same as above. Ive tried 
amending, jus one and then tow, three and all four to see if it made a 
difference, but always the

Ive tried googling for this and can find nothing as in zero found !

if anyone has any idea, please let me know (or if there is anything I 
should report bugwise)



More information about the PyQt mailing list