[PyKDE] Installing eric3

Sergei Mikhailov sergei at gwu.edu
Sun Feb 1 02:49:01 GMT 2004

I am trying to install eric3, the pythong ide. eric3's README said that first Qt, QScintilla, Sip, and PyQt need to be installed. QT was alrady installed on my system, so I started with QScintilla.

I tried installing all these libraries from rpms, but it did not work, so I tried from source. When making qscintilla, the following error occurs. 

/usr/bin/ld: cannot find -lXext
collect2: ld returned 1 exit status
make: *** [/usr/lib/qt-3.1/lib/libqscintilla.so.3.0.0] Error 1

I looked in the Makefile and the line that causes this is:
LIBS     = $(SUBLIBS) -L$(QTDIR)/lib -L/usr/X11R6/lib -lqt-mt -lXext -lX11 -lm -lpthread

I tried removing -lXext (probably not a good idea), it errored out on the next flag, -lX11. When I took that out, if finished ok. 

When I started installing SIP from source, same errors occured. I do not want to proceed to installing PyQt and Eric until I resolve these errors.

BTW, the reason why rpm installation did not work is because when eric was loading, it could not find the qtext module.

Any advise appriciated.

More information about the PyQt mailing list