[PyKDE] Xft related crash

Stephan Jaensch sjaensch at gmx.net
Tue Dec 17 21:44:01 GMT 2002

On Tuesday 17 December 2002 20:04, Phil Thompson wrote:
> On Tuesday 17 December 2002 6:56 pm, Stephan Jaensch wrote:
> > Hi,
> >
> > eric crashes when Xft is enabled for me via qtconfig (anti-aliasing does
> > not have to be used). The QScintilla component seems to be the culprit,
> > as it happens when I click on "New" or try to open an existing document.
> > Here is the backtrace:


> > I'm using current qt-copy from KDE cvs with SIP 3.5, PyQt 3.5, QScintilla
> > 0.3 and eric 3.0 (all self-compiled) on a Debian unstable system. Any
> > hints? I tried on a stock SuSE 8.0 with Qt 3.0.3 and above SIP, PyQt,
> > QScintilla and eric versions and it worked like a charm. Any hints as to
> > what went wrong on the debian system? Any help is appreciated.
> Qt snapshots (assuming that's what qt-copy is) are not supported. Whether
> this has anything to do with the problem...

Yes, qt-copy is a snapshot of Qt. However, I was able to nail down the 
problem: If I choose to substitute the Helvetica font with a Xft-rendered 
font (e.g. Arial) I get the crash. If Helvetica is substituted with a 
non-Xft-font (e.g. Times) or not subsituted at all eric runs fine. I think 
this is a bug since I haven't had any problems with other Qt-based 
applications. I will try tomorrow with the SuSE 8.0 box just to verify that 
this bug is not specific to my Qt snapshot version.


More information about the PyQt mailing list