[PyKDE] pyuic

Boudewijn Rempt bsarempt at xs4all.nl
Sat Jul 7 23:54:10 BST 2001

On Sat, 7 Jul 2001, Jonathan Gardner wrote:

> I'm running SuSE 7.1 on an i386. I installed all the default rpm's (PyQt and 
> sip, they're both version 2.2). Everything works great, except there is a bug 
> in pyuic where it fails to insert a "self." every once in a while. I am 
> pretty sure a bug like this would've been caught between version 2.2 and 2.4.
> So I went to download 2.4, and I can't get the thing to compile. I've tried 
> it with the default qt library, with qt 2.2.3 library and I've tried a lot of 
> different combinations. Do I need qt 2.3.1 in order to get it all to compile?

I use SuSE 7.1 myself, and was forced to compile PyQt on a clean system
yesterday myself, and I didnt't have a problem - but I must say that I
did install Python 2.1 in /usr/local myself. Have you compiled & installed
sip succesfully? You cannot use PyQt 2.4 with sip 2.2. Can you give us
a bit more of what goes wrong on compilation?

More information about the PyQt mailing list